Tomcat Java

We are currentlly unable to install Tomcat-Java on VPS and Dedicated Servers that have been provisioned with EasyApache4

Apache Tomcat, or simply Tomcat (formerly known as Jakarta Tomcat), is an open source web server and servlet container developed by the Apache Software Foundation (ASF). Tomcat implements the Java Servlet and the JavaServer Pages (JSP) specifications from Sun Microsystems and provides a "pure Java" HTTP web server environment for Java code to run.

Hosting Requirements for Tomcat Java

Tomcat Java is not available on Shared or Reseller servers; however, it is available for the following:

  • Linux or Windows Dedicated Server.
  • VPS Snappy 2000 or higher.

For Linux, Tomcat is installed as an addon in cPanel; for Windows, it is installed as an addon in Plesk.

Available Installation Versions of Tomcat Java

Our admins can install Tomcat 5.5 or 7 free of charge on Windows Dedicated Servers with Plesk. Linux VPS/Dedicated Server plans that have cPanel can only install Tomcat 7 at this time, due to the removal of version 5.5 from EasyApache. It is important to note, however, that Tomcat 5.5 does not support Java 1.7.

If you require installation of Tomcat version 6, please contact us via phone or Live Chat to request a quote.

For versions 6 and 7, the default version of the Java JDK we install is 1.6.  If 1.7 is required, please mention that when contacting support.
Note: Once Tomcat has been installed on the server, we cannot provide any support for configuring or setting up the Java applications.