How to enable PHP4, PHP5

New servers and old servers are upgraded to PHP 5 as the new default. PHP 4 is no longer supported, although some older servers may still have PHP 4 installed.

PHP 5 Support

You do not need to do anything to enable PHP 5. It is already installed and ready to go on all of our hosting plans.

To see what versions of PHP 5 are available on your hosting plan, please read our article on:

PHP 4 Support

Note: cPanel announced that EasyApache will no longer support PHP 4 beginning May, 2012.

Shared hosting servers provisioned before May 1, 2013 may still have PHP 4 installed, however we do not guarantee that it will continue to be supported on those servers and may be removed at any time. Please upgrade your existing scripts to use PHP 5 as soon as possible to avoid issues in the future.

If your server still has PHP 4, you can enable PHP 4 by adding this code to your .htaccess file in the folder where you want the changes to apply.

AddHandler application/x-httpd-php4 .php

It is not possible to switch to a server with PHP 4. It is recommended you start using PHP 5 instead.