Plesk System Requirements

Compatible Operating Systems:

  • Linux:
    • CentOS 7.x
    • CentOS 6.x
    • CentOS 5.x
    • CloudLinux 6.x
    • CloudLinux 5.x
    • Debian 7.0
    • Debian 6.0
    • openSUSE 13.1
    • openSUSE 12.3 (EOL: September 15, 2014)
    • RedHat Enterprise Linux 7.x
    • RedHat Enterprise Linux 6.x
    • RedHat Enterprise Linux 5.x
    • Ubuntu 14.04 Server LTS
    • Ubuntu 12.04 Server LTS
    • Ubuntu 10.04 Server LTS (EOL: April 1, 2015)
  • Windows:
    • Windows Server 2008 R2 SP1 (EOL: January 13, 2017)
    • Windows Server 2008 SP2 (EOL: January 13, 2017)
    • Windows Server 2012 R2

BOLD = Indicates a Parallels-recommended operating system
EOL = Indicates the OS is at End of Life for support and will not be available for use in future revisions.

Incompatible Operating Systems:

  • Fedora
  • Debian GNU/Linux 4
  • openSUSE 10.3
  • openSUSE 11.0
  • openSUSE 11.1

Hardware Requirements

  • For Linux:
    • 512 MB of RAM (1 GB when hosting many accounts; 768 MB minimum when also using Web Presence Builder)
    • 10 GB Hard Disk
  • For Windows:
    • 1 GB of RAM (2 GB when hosting many accounts to allow for a reasonable amount of swap space*)
    • 32 GB Hard Disk

Supported Browsers

  • Firefox 30.0 and above
  • Microsoft Internet Explorer 8, 9, 10
  • Safari 7.0 and above
  • Google Chrome 35.0 and above

Mail Client Requirements

Any mail client supporting SMTP, POP or IMAP. Plesk documentation describes setting up MS Outlook, MS Outlook Express, Apple Mail and Mozilla Thunderbird to work with Plesk mail.

Supported Mail Servers

  • Qmail 1.03
  • Postfix 2.6-2.9
  • MailEnable Standard/Professional/Enterprise 5.10-8.5
  • SmarterMail 6.8-12.0
  • IceWarp Mail Server 10.0-10.4.5